PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. Jorn
  2. PLCnext Engineer
  3. Friday, 20 November 2020

Good morning.

Received the PLCnext starterkit this week, did some research on some topics beforehand.

One being the IP address and how to change it, I've tried this makers blog which gave problems with profinet stack and thus the PLC not booting at all.

Also tried the suggestion in this post, whenever I 'write' the IP parameters where I changed the assignment to DHCP, and read the parameters again it will jump back to static...

Have to say I did manage to change the IP address through the online parameters once, only was the static IP I had setup out of range on the project IP range so that didn't work.

 

I'm kind off out of ideas at the moment, would appreciate some help or comment on what's going wrong.

 

Kind regards,

Jorn

 

Software engineer

Alewijnse Marine

Netherlands

Accepted Answer
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

OK, so that screen shot looks good.

You can change the range of valid IP addresses in the main "Project" page - just select the "Settings" tab you can see in the screen shot above.

After setting the address range to a range that suits you, change the IP address of the PLC in the project.

Then, you can transfer the offline IP address information to the online PLC, from the window in your screen shot above. When you press the Search button in the "Online Controllers" tab, the PLC will appear with the "old" address details.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Jorn,

I hope I can help.

  • What LEDs do you see on the PLC? In order to set the IP address from PLCnext Engineer, the RUN LED must be solid green on the PLC.
  • In the PLCnext Engineer "help" system, there is a page titled "Quickstart: Overview on Engineering Steps". On that page there is a section on "IP configuration", which describes how to set the IP address from within PLCnext Engineer. If this does not work for you, can you tell us at what point in this procedure the problem occurs?

EDIT: There is also a section in the PLCnext Technology Info Center that explains how to assign the IP address to a PLC using PLCnext Engineer:
https://www.plcnext.help/te/PLCnext_Engineer/Connecting_to_the_controller.htm

Regards,
Martin.

 

 

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

  1. one week ago
  2. PLCnext Engineer
  3. # 1
Jorn Accepted Answer Pending Moderation
0
Votes
Undo

Hi Martin,

Thank you for your reply.

The 'run' and 'D' led are both green, 'BF-D' is flashing red. 

I have tried both methods from the Help quickstart.

I can't seem to edit the IP address in the 'Online devices' tab, see below picture.

 Untitled picture

 

The offline methode also doesnt work, since the IP I want to give the PLC is outside the standard range.

When I change the range on the project page I can't access the PLC anymore.

 

Software engineer

Alewijnse Marine

Netherlands

  1. one week ago
  2. PLCnext Engineer
  3. # 2
Jorn Accepted Answer Pending Moderation
0
Votes
Undo

OK, so that screen shot looks good.

You can change the range of valid IP addresses in the main "Project" page - just select the "Settings" tab you can see in the screen shot above.

After setting the address range to a range that suits you, change the IP address of the PLC in the project.

Then, you can transfer the offline IP address information to the online PLC, from the window in your screen shot above. When you press the Search button in the "Online Controllers" tab, the PLC will appear with the "old" address details.

Not quite sure why, but this somehow worked now!

So thank you :)

Kind regards,

Jorn

Software engineer

Alewijnse Marine

Netherlands

  1. one week ago
  2. PLCnext Engineer
  3. # 3
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.