Store PLCnext CommunityPLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. d_austin
  2. Proficloud
  3. Friday, 05 March 2021

Good day,

 

I have a problem with the timestamps on my data in the Time Series Data Service.

I understand the TSDS uses UTC but my PLC is set to my local time UTC+2. When the data is saved in the cloud the real-time data is recorded as being 2 hours ahead of my local time.

What can I do to make the latest data coming in match my local time?

 

Thanks,

Damian

 

Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo
Hi,
the PLCnext needs to be set to UTC Time, then TSD will show the correct date (derived from the browser settings).
Phoenix Contact Electronics Headquarter
  1. more than a month ago
  2. Proficloud
  3. # 1
d_austin Accepted Answer Pending Moderation
0
Votes
Undo
Hi Arno,

Thanks for the suggestion.
My concern is that I have a datalogger instance running on my PLC as a backup in case the TSD misses data due to an internet connectivity issue.

If I change the PLC time to UTC then my timestamps for the datalogger service will be off by 2 hours.
  1. more than a month ago
  2. Proficloud
  3. # 2
Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo
HI,

yes I understand the situation, but as the PLC provides only one time and the proficloud requires UTC there may be a solution in the proficloud.
In the settings in the dahboard there is an option for changing the timezone (see attachements). Maybe this can solve your requirement?

Regards, Arno
Attachments (2)
Phoenix Contact Electronics Headquarter
  1. more than a month ago
  2. Proficloud
  3. # 3
d_austin Accepted Answer Pending Moderation
0
Votes
Undo
Hi Arno,
That setting was already on 'Local browser time'
I changed it to UTC time and now the timestamps in the TSD are correct.

If I set the display time range now the most recent 2 hours aren't displayed but that is less important than the timestamps being correct.

Thank you for your assistance,
Damian
  1. more than a month ago
  2. Proficloud
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.