PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. Rob Huisken
  2. PLCnext Technology & PLCnext Controls
  3. Friday, 06 November 2020

Is there a way to disable the https redirect  for the web HMI? We would like to use a web panel that does not support https. 

 

Thanks, 

Rob

Automation Engineer - Grand Rapids, MI, USA

Accepted Answer
Oliver PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello Rob,

this is what you could do. 
Please note that you are disabling all security in this case!


How To http ehmi and WBM:
1. Disable authentication in WBM -> Security (If you want the WBM to be accessable)

2. Modify on the PLC
nano /etc/nginx/nginx.conf
modify the line 
"listen 443 ssl;"
to 
"listen 81;"

3. restart nginx
/etc/init.d/nginx restart

4. disable login in your EHMI page.
5. http://192.168.1.10:81/ehmi/hmiapp.html
6. https://192.168.1.10:81/wbm

Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

Frank PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hey Rob,

sorry for the long response time.

The problem is here, that this against our security concept and architecture.

We are checking currently if this can be done without harm other components.

Keep you informed.

Frank


Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.