PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. Dan Clark
  2. Container @ PLCnext (Docker, Moby, balena)
  3. Wednesday, 05 August 2020

Hello,

I just upgraded to FW 2020.6, and when I follow the instructions on the script for installing Docker it gives me the attached error. I can not run the docker command as shown as well.

 

Attachments (1)
Accepted Answer
jan.mueller@phoenixcontact.de Accepted Answer Pending Moderation
0
Votes
Undo

Hi Dan, 

 

the installation script for docker has a little mistake. I have fixed it. The actually version is on GitHub. 

 

Greetings, 

Jan

Stefan Brinkmann Accepted Answer Pending Moderation
0
Votes
Undo

Hi Dan,

have you tried the first option (balenaEngine)? I installed that yesterday with FW 2020.6. 

balenaEngine is 100% compatible with docker but has some additional features like 3.5 times smaller binaries.

jan.mueller@phoenixcontact.de Accepted Answer Pending Moderation
0
Votes
Undo

Hi Dan, 

 

the script does not download the docker bin.

 

1.) Has the controller internet access?

2.) Can you please give me the output of "curl -ssl -v https://google.de"

Dan Clark Accepted Answer Pending Moderation
0
Votes
Undo

Stefan,

I would like to use docker, as that is what I have used in the past for this implantation.

 

Jan,

  1. The controller does have internet access.
  2. See attached picture. 

 

Thanks!

Attachments (1)
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.