PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. Stefan Brinkmann
  2. Container @ PLCnext (Docker, Moby, balena)
  3. Thursday, 13 August 2020

I have installed balenaEngine on an AXC F 2152 with Firmware 2020.6 using the procedure described on Github. The installation works fine but what I found out is that the firewall is activated after the installation.

Thus it is not possible to access e.g. node-red.

Here is what I have tried:

  1. Permanently deactivat the firewall: The checkbox in the Activate field is not activated but the firewall is activated after a reboot anyway
  2. stop the firewall: manually stopping the firewall works after selecting stop several times. After that I can access node-red-. But this is only a temporary solution.
  3. Setting up incoming and outgoing rules on the firewall to allow all ports: I still cannot access node-red.

Is this the intended behaviour? How can I permanently deactivate the firewall?

This has been tried out on different controllers and they all show the same behaviour.

Accepted Answer
jan.mueller@phoenixcontact.de Accepted Answer Pending Moderation
0
Votes
Undo

Hi Stefan,

 

please see the workaround on GitHub to deactivate the firewall.

 

As soon as firewall rules with the table name Filter are present, the PLCnext firewall thinks it is started. The table is also created by Balena or Docker.

The adjustment can probably only be made to FW2021.



There are replies in this post but you are not allowed to view the replies from this post.