PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. dhoysan
  2. Proficloud
  3. Monday, 06 January 2020

I have a Cloud IoT Gateway set to read discrete inputs from a Modbus device. The Gateway correctly updates when the value changes from false to true, however I cannot get this data to display correctly on Proficloud. I tried using the Singlestat panel to display this data, however the Singlestat remains 0 even though the value is true.

Can the Singlestat panel display discrete inputs? Is there another panel that should be used instead?

Cloud IoT Gateway inputs are true

Singlestat panel shows 0

Accepted Answer
dhoysan Accepted Answer Pending Moderation
0
Votes
Undo

Thanks for the quick turn around!

  1. more than a month ago
  2. Proficloud
  3. # Permalink
Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

did you try to set the value mapping to:

false = 0

true = 1

I am sure that I have used bollean with singlestat in the past to display on/off information. 


Phoenix Contact Electronics Headquarter - Support Center

  1. more than a month ago
  2. Proficloud
  3. # 1
dhoysan Accepted Answer Pending Moderation
0
Votes
Undo

Hi Arno,

Yes I have tried value mapping, but since the singlestat never changes the value mapping never changes....Any other thoughts or suggestions?

  1. more than a month ago
  2. Proficloud
  3. # 2
dhoysan Accepted Answer Pending Moderation
0
Votes
Undo

Any additional thoughts?

  1. more than a month ago
  2. Proficloud
  3. # 3
Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Dave,

Did you check the stat is "Current"

Options -> Value: Stat: "Current"

Default is "Average"...which would explain that the value does not change immediatelly.

Arno

Current

 


Phoenix Contact Electronics Headquarter - Support Center

  1. more than a month ago
  2. Proficloud
  3. # 4
dhoysan Accepted Answer Pending Moderation
0
Votes
Undo

Hi Arno,

None of the panels appear to show the data correctly. I’ve included a screenshot showing what the Cloud IoT Gateway was reading at 11:29 today, and the corresponding table on Proficloud with the same metrics added. As you can see, the Proficloud is not displaying either "1" or “true”. The Proficloud logs the data in real time (I’ve verified there are no time sync issues), but still will not show these Boolean values.

Has anyone on your team tested Read Coils on the Proficloud before?

Do you think we might need the discrete panel in order to display this data: https://grafana.com/grafana/plugins/natel-discrete-panel

 

Boolean not displaying on chartBoolean value in Cloud IoT GW

Cloud IoT Gateway setup

  1. more than a month ago
  2. Proficloud
  3. # 5
Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

we finally could also reproduce the issue. We will come back with a solution very soon. We think that it could be an issue with the TSD collector in the proficloud. Sorry for any inconvenience.


Phoenix Contact Electronics Headquarter - Support Center

  1. more than a month ago
  2. Proficloud
  3. # 6
Arno PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi, we have tested the problem with the boolean values in the IoT Gateway. The problem was not in the IoT Gateway, but in the TSD collectors in the cloud. We have fixed the parsing of "true" and "false". Now we have updated it and the values are correctly captured and displayed in proficloud.


Phoenix Contact Electronics Headquarter - Support Center

  1. more than a month ago
  2. Proficloud
  3. # 7
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.