Store PLCnext CommunityPLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. diwa130
  2. PLCnext Technology & PLCnext Controls
  3. Thursday, 17 December 2020

How can I install this package on PlcNext ? 

arm-pxc-linux-gnueabi-gcc

 

Thank You

 

Eduard PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello diwa130,

the compiler "arm-pxc-linux-gnueabi-gcc" is a part of PLCnext SDK, it is available for Linux 64 System (and Windows 32Bit/64Bit Systems).

Is there a reason, why you need to install the "arm-pxc-linux-gnueabi-gcc" on PLCnext Controller ?

You can also use the Windows or Linux OS for project build, it is faster and you will avoid a lot of PLC limitations.

Best Regards,

Eduard


Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

jan.mueller@phoenixcontact.de Accepted Answer Pending Moderation
0
Votes
Undo

To compile python packages for example :).

You can use ipkg or dpkg packages for this, but they may lack the necessary dependencies. I haven't dared to do this yet, it usually turns into a lot of work.

What exactly do you want to do?

diwa130 Accepted Answer Pending Moderation
0
Votes
Undo

I need confluent-kafka and when I try to install , I get the following  

   " unable to execute 'arm-pxc-linux-gnueabi-gcc': No such file or directory  "

Thank You

 

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.