PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. jfsimon
  2. PLCnext Technology & PLCnext Controls
  3. Friday, 16 October 2020

Good evening,

 

After installing plcncli and starting the extraction :

plcncli install sdk -p pxc-glibc-x86_64-axcf2152-image-sdk-cortexa9t2hf-neon-axcf2152-toolchain-2020.0.sh -d /opt/pxc/sdk/AXCF2152/2020.0

 

I got an error:

The format of the file '/home/jeanfrancois/plcncli/pxc-glibc-x86_64-axcf2152-image-sdk-cortexa9t2hf-neon-axcf2152-toolchain-2020.0.sh' is not supported. Please proceed manually.

 

Can you please help me ?

 

Thank you,

 

Jean-François Simon

Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Jean-François

I can replicate a similar error:

The format of the file '/home/tcs-user/Downloads/pxc-glibc-x86_64-rfc4072s-image-sdk-corei7-64-rfc480-64-toolchain-2020.6.sh' is not supported. Please proceed manually.
-> An exception occured while inspecting the script.
Permission denied
-> Permission denied

This happens if the current user does not have execute permission on the .sh file. This is indicated by the "Permission denied" message. Do you also see this message? Can you confirm that the user has execute permission on the .sh file?

Regards,
Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.