PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. wanrong
  2. PLCnext Technology & PLCnext Controls
  3. Wednesday, 25 March 2020

Hi guys,

  Recently I am trying to install ali iot link edge, which is a binary program, to axcf 2152.  axcf 2152 is running with FW 2020.0 LTS.

  I am faced with nginx service launch failure.  for the log trace I got some hints below:

020-03-25 05:42:02.983421 [main.cpp|126] wait pid(4740) status(256)020-03-25 05:42:02.983421 [main.cpp|126] wait pid(4740) status(256)2020-03-25 05:42:02.984041 [service_manager.cpp|208] process_exit, pid:47402020-03-25 05:42:03.201370 [service_manager.cpp|219] process_exit, service(nginx) is abnormal2020-03-25 05:42:31.294938 [service_manager.cpp|313] threadProc, service(nginx) status(2) is abnormal2020-03-25 05:42:31.313905 [service_control.cpp|238] run nginx pid 4743

  In fact, I have successfully running the binary program on a virtual machine linux environment, which has no nginx regarding service installation before. But for axcf 2152, it is apparent that it has already equipted with nginx service right before the iot link edge installation. I am doubting whethe the failure is caused by this difference.

  So, can anyone give me some suggestion? by the way, I am als trying to look for help from the iot link edge support team.

 

 

 

Attachments (1)
Accepted Answer
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Wan Rong,

I have discussed this with my colleagues here.

It may be that the binary program you are running tries to start up its own nginx service - similar to all the other services listed in your screen shot. Since nginx is already running on the PLC, this may cause the second nginx service to fail.

If this theory is correct, then I am not sure what the solution is. Some things you could try:

  • Disable nginx on the PLC. I would not recommend this, because this nginx service is used by a few PLC components, including WBM and eHMI.
  • Configure the "other" nginx service (the one started by your binary) in such a way that it does not conflict with the nginx service that is already on the PLC. For example, both nginx services may be trying to bind to the same port (e.g. port 443), so you could try changing this on one of the instances, if possible.
  • Somehow configure your binary to use the nginx service that is already installed on the PLC, rather than trying to start its own nginx service.

I hope this gives you some clues.

Perhaps the iot link edge support team can advise how to handle the case where nginx is already installed on the host machine.

~ Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

wanrong Accepted Answer Pending Moderation
0
Votes
Undo

thanks Martin

I tried your second suggestio--find potential conflict port, and I really find the root of the issue.  our PLC, somehow, open the localhost port 9999, which is the same port required by link iot edge.

so I am asking another question: why PLC open the 9999 port, and can I modify its behavior?  what's the influence if I changed this port?

can anyone give me the indication?

Attachments (1)
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Wan Rong,

Port 9999 is an internal port used by the eHMI feature.

You can free up this port by disabling the eHMI feature, using the procedure described in this Makers Blog post:

https://www.plcnext-community.net/en/hn-makers-blog/440-how-to-disable-system-components-in-the-plc-for-more-performance.html

If you want to use both the eHMI and the link iot edge app, then I hope you can find a way to change the port used by link iot edge.

~ Martin.

 

 

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

wanrong Accepted Answer Pending Moderation
0
Votes
Undo

Thanks again Martin,

  I have foud it feasible to change the link iot edge port, so this would not be a problem anymore.

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.