PLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. skraetzig
  2. PLCnext Technology & PLCnext Controls
  3. Thursday, 06 February 2020

Dear community,

at the moment I am trying to connect the PLCnext with Node Red over UPC-UA.

The goal is to read data form the PLCnext and display it on Node Red.

After installing node-red-contrib-iiot-opcua with version 2.7.1 an exception raised -  openssl could not create certificate files.

I noticed that there is a solution for this problem in the community (https://www.plcnext-community.net/en/hn-makers-blog/419-problems-with-node-red-opc-ua.html) and I followed the instructions to solve it.

The node red server runs and the nodes for OPCUA connection are available. As the certificate was added manual I configured a flow the same way as in the tutorial (https://www.plcnext-community.net/en/hn-makers-blog/301-automation-maker-003-node-red-as-opc-ua-client.html).

 

There was a strange behaviour.

If I set the security mode to "sign&encrypt" the node tries to connect but it is never successfull.

If I change it to "none" security mode the connection is "active".

But if the flow gets injected then an error arises: "Error: Client not open on read".

I tried different versions and configurations but never was able to read the opc values over Node Red.

With the UA-Expert client it is possible to read and write the OPC-UA values.

My actual environment:

PLCnext Firmware : 2020.0

Node.js           : 10.15.3 - installed from PLCnext Store

npm version   : 6.4.1

Node-red        : 0.20.5

node-red-contrib-iiot-opcua : 2.7.1

 

Anyone of you had the same problem?

Maybe someone could write his configuration with node red and OPC-UA running.

 

Best regards

Steffen Krätzig

 

Attachments (1)
Accepted Answer
Stefan Brinkmann Accepted Answer Pending Moderation
0
Votes
Undo

When I try to connect to the OPC UA server with the latest version of the opcua nodes, I get the following message in node-red:

Error: End point must exist opc.tcp://192.168.178.10:4840/

Using UAExpert to connect with the above URL it works.

When I use the node-red-contrib-opcua nodes everything works like expected.

Stefan Brinkmann Accepted Answer Pending Moderation
0
Votes
Undo

I tried the same with node-red-contrib-iiot-opcua Version 2.7.1. The read node shows "connecting..." and after a few seconds, the connection to node-red is lost and I have to restart my PLC. The PLC itself is still running. So at the moment I do not know how to solve this issue.

If someone has successfully used the OPC UA nodes with the AXC please share your experience. 

 

Just for testing I have installed the latest version on my raspberry pi. The installation works without any problems but when I deploy my flow, the read node stays on connecting forever. So at the moment I have no idea where to look for the problems.

Stefan Brinkmann Accepted Answer Pending Moderation
0
Votes
Undo

I finally managed to install the latest version of the node-red-contrib-iiot-opcua.

Here are my steps:

 

1. Update node-gyp: 

npm install -g node-gyp@latest

2
. install ipkg (see makers blog)

3. install gcc

4. install make

5. install opcua : npm install -g node-red-contrib-iiot-opcua --unsafe-perm --build-from-source


  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.