Store PLCnext CommunityPLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. jlucci
  2. Container @ PLCnext (Docker, Moby, balena)
  3. Wednesday, 07 April 2021
Hi. I cant use node-red on my plc AXC F2152, A have already installed python 3, npm node.js and node-red, but when I tried to start node-red result below:


/opt/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/api/flows.js:52
getFlows: async function(opts) {
^^^^^^^^

SyntaxError: Unexpected token function
at createScript (vm.js:56:10)
at Object.runInThisContext (vm.js:97:10)
at Module._compile (module.js:542:28)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object.<anonymous> (/opt/lib/node_modules/node-red/node_modules/@node-red/runtime/lib/api/index.js:34:12)


Thanks in advance

Regards
Dries Van Laerhoven Accepted Answer Pending Moderation
0
Votes
Undo
Hi

It looks like your using the first installation method, I'm not familiar with that one.
Maybe this blog can help you install node-red in a different manner:

https://www.plcnext-community.net/en/hn-makers-blog/481-node-red-and-getting-started-with-docker.html

With kind regards

Dries
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.