PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. brendantrichart
  2. PLCnext Technology & PLCnext Controls
  3. Tuesday, 11 February 2020

2020-02-10_18h17_12.pngWhen trying to compile the C++ program in the youtube video into my controller, I have ran into an issue where I get an error that says it could not upload onto the controller.

Here's some thing I noticed:

 1) When I run the IEC 6113 program from the youtube it works well and that project is a 2019 project

2) When I try to upload the library onto an AXCF 2152 2019.XX project, I get an error that says "PLCNEXT0007: The library 'BTRTest2' does not support the controller 'axc-f-2152-1.'"

3) In lieu of item 2) above I follow the C++ youtube video, compile, and try to run the project on the purchased AXCF 2152 but it won't upload onto the controller.

4) Lastly, when I try to create a new project of any version, I don't get the same screen on 3:47 on your you tube video. Instead, I get what is seen below with no Cyclic100/Maintenance to place the program task into. This only started happening within the past 24 hours whereas before I was able to completely emulate everything did in the youtube video short of uploading onto the controller as mentioned in item 3)

 

2020-02-10_18h17_12.png

 

Can you please advise?

 

Thanks,

 

Brendan

 

Accepted Answer
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Brendan,

The version of the controller you select in PLCnext Engineer must match the version of firmware running on the controller.

You can upgrade the firmware on the controller itself using this procedure.

The version of the controller you are using in PLCnext Engineer can be selected when you first create a new project, by clicking on the template for the controller version you want. If you want to change the version of the controller in an existing project, you can use this procedure.

If you don't see an AXC F 2152 with firmware version 2020.0 in PLCnext Engineer, please make sure you are running the latest version of PLCnext Engineer (2020.0). You can download this version of PLCnext Engineer from our website.

~ Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support

Eduard PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello Brendan,

please verify the controller version in your PLCnEng project (Node -> axcf2152:AXCF2152 -> Settings), the SDK-Version (C++ Project) and the Controller FW-Version (admin@axcf2152:~$ cat /etc/plcnext/arpversion).

The controller version in PLCnEng-Project, SDK and FW must be the same e.g. 2019.9. In this case please install the PLCnext Engineer 2020.0 and create a PLCnEng-Project for AXCF2152 2019.9 controller and try to include the C++ library. 

Thanks & Best Regards

Eduard 


Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

brendantrichart Accepted Answer Pending Moderation
0
Votes
Undo

Hey Eduard, thanks for the response

When I check the node of the project that works, it shows version number 00/2019.00 under axc-f-2152-1: AXC F2152/settings. When attempting to start a new eclipse
Plcnext project it shows a 'AXCF2152, 2020.0 LTS' available target.

I tried to upload the library on a new project that I started with a 2019.9 controller project and I got the same error as shown above. Is there a possibility I can upgrade
the firmware on the controller itself and how would I do this?

 

Thanks,

 

Brendan

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.