PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. jmay
  2. PLCnext Technology & PLCnext Controls
  3. Thursday, 19 November 2020

HI,

 

i installed node-red on the controller and try to access it via opc ua. But if try to deploy a flow with opc ua, i got this error:

"Error: get-installed-path: module not found "node-opcua-client" in path /opt/plcnext/appshome/data/60002172000051/lib/node_modules/node-red-contrib-opcua/node-opcua-client"

 

I installed node-red-contrib-opcua 0.2.89 via the cli, FW of the controller is 2020.6.1

 

Does anybody have an idea why the client is missing?

 

Regards

Jochen

Stefan Brinkmann Accepted Answer Pending Moderation
0
Votes
Undo

Hello Jochen,

have you installed an app on your PLC? The message seems to come from an app on the PLC. Where did you install node red? The preferred way to install node-red on the PLC is via balena-engine. This works without problems. Maybe this will help: 

https://www.plcnext-community.net/en/hn-makers-blog/481-node-red-and-getting-started-with-docker.html

jmay Accepted Answer Pending Moderation
0
Votes
Undo

Hi Stefan,

 

i installed via the AppStore. So i will try to uninstall it and use the link which you provided.

 

 

jmay Accepted Answer Pending Moderation
0
Votes
Undo

So i try it like in the link descriped and it works. it was also possible to install a packages. But after a reboot the container is not able to connect to the internet. Also the firewall status in the wbm is a little odd - i only get a circe running, and no text in the background. So i got no idea what the problem is..... Do you have any idea?

I also run  "update-rc.d -f firewall remove" but this make no difference

 

 

For the Records:

I reset the controller to factory settings and try it again. At this time everything was working like expected and there was no problems. Node-Red is working and i can install flows at any time.

 

Attachments (1)
Oliver PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello,
that loading screen is normal for the 2020.6 workaround.
Deactivated the Firewall manually means that the service is not running that supplies the data...

This workaround will no longer be necessary with 2021.0

Also if you need to go productive with 2020.6 and need a firewall you can revert back to IP Tables=disabled and then set up the NFT rules like it was done for FW < 2020.6.
kind regards,
Oliver

Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

jmay Accepted Answer Pending Moderation
0
Votes
Undo

Hi,

 

thanks for the reply. For the moment everything is fine and i can live without firewall.

 

Regards

Jochen

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.