Store PLCnext CommunityPLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. Arne Smets
  2. PLCnext Technology & PLCnext Controls
  3. Friday, 04 October 2019

I installed the eclipse plug in succesfully, but I can't add a target. If I  command "plcncli get sdks", I get the error:  "Could not find the SDK. This SDK cannot be used, please remove the SDK from the settings."

How can I solve this?

Oliver PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello Arne,

I guess you still have to install the SDK

have a look at this tutorial.
https://www.youtube.com/watch?v=UNbNv7eBHPE

 

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

Is it important to use the Eclipse IDE neon 3 (2017 version), or is the newest eclipse IDE also compatible?

Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hi Arne,

We have recently discovered that our Eclipse add-in is not compatible with the latest version of Eclipse IDE. Please use the version of Eclipse IDE recommended in the PLCnext Technology user manual, which can be downloaded here:

https://www.eclipse.org/downloads/packages/release/photon/r/eclipse-ide-cc-developers

Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

In what part is it not compatible?

If I download the isntaller from the link, I still get the newest version of Eclipse, 2019-09.. Everthing seems fine, except for the sdk, because I am not able to add targets (non available) in the ide. But the PLCNext options are all there. I installed the SDK as in the tutorial and after installations I get the message "installation succesfull".  So that's where I got stuck right now..

 

Arne

 

Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

OK, just so I understand ... the problem in the original post was that the command "plcncli get sdks" gave an error message. This is not related to Eclipse. Is this still the problem that you are having?

Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

Ah I see it. I first installed 2019-06, which worked fine. Now I just downloaded 2019-9, which is giving me an error indeed. So only newest version is causing problems.

 

Then the SDK. I installed it with the exact same directories as in the video and after installation I get "installation complete".

Then I get this error: attachment

 

Arne

Attachments (2)
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

OK. Exactly which SDK did you install? i.e. for which Host system (linux 32 bit, linux 64 bit or Windows), and for which AXC F 2152 firmware version?

Martin.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

pxc-glibc-x86_64-axcf2152-image-mingw-cortexa9t2hf-neon-toolchain-2019.6.tar.xz

So for windows, as I run everthing on windows 10, and firmware 2019.6.

The firmware on the PLCNext right now is 2019.9, but before I used 2019.6 and it was the same problem.

I see the 2019.9 SDK is available so I will try that one right now.

Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

I installed the new version in the the same path, only in a new directory called 2019.9 instead 2019. But I get the same error.

I changed the name of the directory in 2019 myself. Before it was 2019.0. If I change it back I get the same error, but then it looks for a SDK in 2019.6 (if I understand it right), but that directory doesn't even exist....

 

So, first error, the SDK is in "2019"

then I changed it to 2019.0, and get the second error (2019.6??).

beside this one I also have 2019.9, where the newest sdk is installed.

Attachments (2)
Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

OK, so I understand that there is an SDK installed in the directory C:\SDKs\AXCF2152\2019.9

What is the result of these commands:

plcncli
plcncli get targets
plcncli set setting SdkPaths C:\SDKs\AXCF2152\2019.9 --add

... and what is the contents of the file: C:\Users\yourusername\AppData\Roaming\plcncli.Common\settings.xml ?

 

 

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
Arne Smets Accepted Answer Pending Moderation
0
Votes
Undo

In the XML file where several SDK's, I deleted them all except for newest version I downloaded this morning and it's showing me the SDK

 

Martin PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

OK, this file must have got some invalid entry(s) somehow ... but glad its fixed.

Phoenix Contact Electronics Headquarters - PLCnext Runtime Product Management and Support
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.