PLCnext on LinkedInPLCnext on Instagram  PLCnext on YouTube Github PLCnext CommunityStore PLCnext Community

  1. hafiz_sallim
  2. PLCnext Technology & PLCnext Controls
  3. Friday, 20 March 2020

Hi there!

I have a AXC F 2152, where the HMI does not seem to be working. Here are some details:

  1. Upon launching the hmi simulator on PLCnext Engineer, I get a blank page
  2. I have updated the firmware to the latest version (2020.1) and it is still the same
  3. When I open up "192.168.1.10", multiple browsers say "connection refused"
  4. I have another set of AXC F 2152, and this set works fine, so it is likely not due to the software
  5. I ssh into both controllers, and ran the "top" command. I noticed that the unresponsive controller does not have the following process running:
    PID: 1122
    PPID: 1118
    USER: www
    COMMAND: nginx: worker process

    PID: 1124
    PPID: 1118
    USER: www
    COMMAND: nginx: worker process
  6. I tried running /etc/init.d/nginx -s reload, but it seems that the admin user does not have sufficient rights to run this

Any ideas on what could be happening here?

Thank you!
-Hafiz

Accepted Answer
Oliver PLCnext Team Accepted Answer Pending Moderation
1
Votes
Undo

Hello Hafiz,

usually the /run or /var/run simply holds pid files to running processes.
So properbly these are not generated or deleted when the Nginx shuts down.

you can try creating a root user to controll the nginx

Did you deploy your own certificates this looks like some format error in one of the Certificat files.

You can also try fixing the date and time on the plc with PLCnext Engineer or with the date -s "2020-03-23 08:49:12"

What you can also try is doing a type one reset.
This should reset generation of certificat files.

kind regards,
Oliver

Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

Oliver PLCnext Team Accepted Answer Pending Moderation
0
Votes
Undo

Hello Hafiz,

please check the FW on the not running PLC

cat /etc/plcnext/arpversion

You could try "sudo /etc/init.d/nginx restart"

I never had trouble with the nginx so far.

please have a look at /var/log/messages and /var/log/nginx so we can find out what is happening there.

kind regards,
Oliver

Phoenix Contact Electronics Headquarter - PLCnext Runtime Product Management and Support

hafiz_sallim Accepted Answer Pending Moderation
0
Votes
Undo

Hi Oliver,

Thank you so much for your reply. Here's the information that I managed to extract:

FW Version running on the 2152:
Arpversion: 20.0.1.26832
Svn Revision: 26832
Build Job: "jenkins-PLCnext-Tocto_AXCF2152-release%@F20.0.x-61"

 

I tried running "sudo nginx restart" but it seems that the admin user does not have sufficient rights to run this command.

Running "nginx -h" yields the following information:
nginx version: nginx/1.15.7
Options:
-s signal :send signal to master process: stop, quit, reopen, reload

Looking at /var/log/nginx/ mentions there is an error with the certificates. Here is the information there:
2019/02/19 11:19:22 [emerg] 1231#1231: PEM_read_bio_X509_AUX("/opt/plcnext/Security/Certificates/https/https_cert.pem") failed (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)

 

Link to messages file:
https://drive.google.com/file/d/1FL7LjAn2NGXhJLe7h3xfxM-KHeZ_3dQT/view?usp=sharing

 

One thing I noticed is that the date and time on the 2152 is incorrect. That might cause an issue with the browser trying to access the web services.

 

Let me know what you think of this,

Thank you!
-Hafiz

 

hafiz_sallim Accepted Answer Pending Moderation
0
Votes
Undo

Upon closer inspection, it seems that the entire /run/nginx/ folder on the faulty 2152 is missing. This could be the reason why the web services is not running in the first place. What would be your advise on the next course of action?

Thanks!
-Hafiz

hafiz_sallim Accepted Answer Pending Moderation
0
Votes
Undo

Hi Oliver,

Doing the Type 1 reset seemed to do the trick! I probably should have tried this first before attempting any other methods. Thank you, you have been a great help!

Thanks,
-Hafiz

  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.